How to apply k8s manifest without scaling replicas



  • We have a manifest file that defines a set number of replicas and an autoscaler that scales them up. The problem we have is when we apply the manifest, it immediately scales the replicas down to the number in the manifest. This eventually is fixed by the autoscaler, but in the meantime, it's not great!

    Is there a way to run a manifest and ignore the replica parameter?

    We tried removing it, but then it scaled to the default count of 1.



  • The application boot up might be using resources above your set utilisation target before settling down. What you can do is to either:

    • give it a bit more resource request
    • increase the threshold of the HPA utilisation target
    • increase the autoscaler interval check



Suggested Topics

  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2