Why is GeForce Experience optimizing my games for a lower resolution?



  • I have a desktop PC with a full HD monitor which supports 1920x1080 60 Hz and an Nvidia GTX 2080 Ti GPU.

    Lately I have noticed GeForce experience wants to optimize my games at 1477x831.

    I first noticed it while playing Final Fantasy XV, but did not give it much thought.

    Currently I am playing Pillars of Eternity and it wants to do the same.

    Pillars of Eternity optimized at lower resolution

    I installed Pillars of Eternity II and same story.

    enter image description here

    In the past it used to optimize games at 1920x1080 correctly. My hardware has remained the same for the last three years.

    When I launch these newly GeForce optimized games, I get an overlay notification saying "Optimum resolution is 1920x1080", which I think might be from my monitor or Windows.

    Why is GeForce Experience optimizing my games for a lower resolution?



  • I think it has to do with Nvidia's Image Scaling. https://www.gpumag.com/nvidia-image-scaling/ has a good explanation about this feature, as does this https://nvidia.custhelp.com/app/answers/detail/a_id/5280/%7E/how-to-enable-nvidia-image-scaling , but basically its a way to gain performance while also trying not to sacrifice too much quality via upscaling.

    NVIDIA Image Scaling is a driver-based spatial upscaler and sharpener for GeForce GPUs for all games. This feature is accessible both from the NVIDIA Control Panel and GeForce Experience, and includes a per-game sharpening setting tunable from NVIDIA’s In-game overlay. It is available for all Directx 9, 10, 11, 12, Vulkan and OpenGL games

    See this picture from the first article for examples of the various upscaling and other performance tools Nvidia has created (hopefully its not compressed too much by imgur, https://www.gpumag.com/wp-content/uploads/2022/02/Scaling-Technologies-Compared.jpg 😞

    upscaling image

    You can see that the Image Scaled example (46FPS one) looks virtually the same (to me) as the FSR 4k image next to it.

    It looks like for 1080p input resolution, at 77% scaling, the input resolution will be 1477 x 831, hence where this number is coming from I believe. Thus I am guessing GeForce Experience is automatically trying to optimize your game to use this image scaling technology to obtain better performance while not sacrificing a perceivable amount of quality.

    You can turn this feature off if you wish via Nvidia Control Panel, or in GeForce experience. Through the control panel:

    1. Right-click on an empty space on your desktop and select Nvidia Control Panel.
    2. Once the Control Panel is open, head over to Manage 3D Settings on the menu on the left.
    3. In front of you should be a list of settings. Look for Image Sharpening (the first one).
    4. Click it, and in the newly opened window, select [off].

    Steps sourced from first article, switched "on" to [off].

    Through GeForce Experience, there should be a toggle for it possibly near the in Game Overlay option. This is also where you can target what render resolution you are aiming for:

    geforce experience location




Suggested Topics

  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2