I am facing difficulties in backing up a database in MS SQL Server



  • enter image description here When I try to backup a database, it is showing this message :

    to accomplish this action set property devices. (microsoft.sqlserver.smoextended)

    I cannot able to select the file location to backup as you can see in the picture that OK button is not enabled.

    I tried to change the permission of folders, but the permissions are not changing.

    Note: I am using MS SQL Server -2022- 2019



  • I see you are using SQL 2019, not SQL 2022. I can see this from both object explorer and also from the backup path. The number 15 is for SQL 2019. SQL 2022 is still in private preview and not yet publicly available.

    I've included a screenshot of how to take a backup using the wizard in SSMS. The OK button is disabled until you enter a name for the backup file.

    enter image description here




Suggested Topics

  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2