Install a fully functional Audible app on Android older than Android 6.0



  • I just bought a Samsung Galaxy S5 Mini, featuring Android 5.1. However, I cannot install the "Audible" audiobook app via Google Play (no search results).

    I know that this should work, as I have the exact same device (bought earlier) where Audible is running (automatic app updates are switched off)

    I tried downloading an older version (Audible-2.16.1) from http://www.apkmirror.com (not sure if the website is trustworthy) and installed it manually using ADB and USB debugging. The app kind of worked. At least I could log in and see my audiobooks. However, when trying to download any of the books, I get error messages.

    I assume that the app tries to connect to the wrong (old) server when downloading.

    Does anybody else have similar problems and knows how to get Audible going on older devices?



  • Audible 3.0.1 ( https://www.apkmirror.com/apk/audible-inc/audiobooks-from-audible/audiobooks-from-audible-3-0-1-release/ ) is the latest version that supports Android 4.1+ before it jumped to requiring a minimum Android version of Android 6.0.


    Some additional clarifications to the question:

    1. Since Audible 3.1.0 (March 25, 2021), the minimum Android version jumped to Android 6.0. This affects the app's visibility in https://play.google.com/store/apps/details?id=com.audible.application since incompatible apps will not be shown when searching directly from the app.
    2. The major version jump from 2.x to 3.x possibly indicates a breaking change including on the backend server-side, thus Audible apps before 3.0.0 might not work properly anymore.
    3. Last but not least, https://android.stackexchange.com/q/135711/44325 .



Suggested Topics

  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2