What version of Kiwi Browser can be installed on Android 5?



  • I have a Samsung SM-P905V tablet that is running Android 5.1.1. Nothing newer is available, and no one has figured out unlocking the bootloader to allow a custom ROM.

    I want to load Kiwi Browser, and have tried to find an older version that will work.

    From https://www.apkmirror.com/apk/geometry-ou/kiwi-browser-fast-quiet/kiwi-browser-fast-quiet-96-0-4664-46-release/kiwi-browser-fast-quiet-96-0-4664-46-5-android-apk-download/ I found com.kiwibrowser.browser_96.0.4664.46-466404611_minAPI21(x86)(nodpi)_apkmirror.com.apk

    The page title is "Kiwi Browser - Fast & Quiet 96.0.4664.46 (x86) (Android 5.0+) Kiwi Browser - Fast & Quiet 96.0.4664.46 (x86) (Android 5.0+)"

    This fails installation - the message is "there was a problem parsing the package"

    I also tried to install kiwi-browser-99-0-4844-94.apk and get a similar error.

    Is there any specific version that will work with Android 5.1.1?



  • Your main problem why you can't install the version com.kiwibrowser.browser_96.0.4664.46-466404611_minAPI21(x86)(nodpi)_apkmirror.com.apk is that this version is only for devices with x86 CPU.

    But your tablet is an Samsung Galaxy Note Pro 12.2 that uses an Qualcomm Snapdragon 800 / Krait 400 CPU (ARMv7). Therefore when downloading an APK file from ApkMirror.com you have to select the armeabi-v7a variant (all the other variants like x86, x86_64 or arm64-v8a will not work on your device).

    Note that using an outdated web browser is invitation for malicious sites to hack and infect your device. You should be really careful about which web site you look at when using such an outdated version.

    So my recommendation would be to switch to a web browser that still supports Android 5.0 like https://play.google.com/store/apps/details?id=org.mozilla.firefox .




Suggested Topics

  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2