Oneplus 7 pro stuck at boot animation



  • I have a rooted Oneplus 7 Pro. Today my phone said that an OTA had finished downloading and to reboot to install the update. I had been postponing this update and decided to finally go through with it.

    I went through all the steps to keep my root, uninstall magisk, download OTA, flash twrp ab retension script, install magisk to inactive slot, and finally reboot. I am now stuck at the boot animation.

    When I try to boot into TWRP, the screen keeps flashing at the TWRP loading screen but I can never actually get into it. I am able to ADB into the phone at this point though and the recovery.log says something about Fatal signal 6 (SIGABRT), code -6 (SI_TKILL) Does anyone know know how to fix this? Any help would be greatly appreciated!

    Edit: I have made a little progress. I was able to change the partition back to the original partition and while I still can't boot, I can get into TWRP now.

    Edit2: I updated my TWRP and can now get into TWRP on both partitions. On the old partition I can decrypt my data with pattern (and was able to back everything up), but on the new partition it is asking for a password and I don't have one. Still get stuck on the boot animation are both partitions. I have also tried uninstalling all my magisk modules (except for one adb one) and that didn't help either.



  • If you are someway able to boot into fastboot, try flashing stock boot.img there (Google might help you in finding stock imgs).

    Otherwise, get the firmware flashing tools for OnePlus and reinstall stock from scratch which but would erase userdata though.




Suggested Topics

  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2