Disabling randomized macs on Android 11



  • Trying to set up a new Moto-G Stylus with Android 11 on an internal wifi network with mac authentication and a hidden ssid. To provide the expected mac, I selected "Use device MAC" (which is correctly displayed in the connection setup), but the phone continues to send random values.

    No problem connecting when mac authentication was temporarily disabled on the AP. Repeated forget/re-entering the AP info and resets of the Android networking haven't changed the random behavior. Seems like a bug where the "Use device MAC" is simply being ignored.

    The phone will be useless without a fix and I can't think of anything else to try. Any suggestions or workarounds would be greatly appreciated.

    Thanks,

    -Tom



  • Android has three MAC modes:

    Persistent MAC randomization

    This should be the default mode. For each Wifi a new random MAC address is generated. But if you reconnect to an already known Wifi the same random MAC address is used.

    Non-persistent MAC randomization

    In this mode for each Wifi a new random MAC address is generated and this MAC address only persists unless you disconnect from the Wifi. If you reconnect to a known Wifi again a new MAC address is generated.

    No randomization (device MAC)

    Disables all randomization for the specified Wifi, only the device MAC is used.

    From your description I would assume that on your device non-persistent MAC randomization is active. As you have seen persitent randomization and device MAC can be activated in Wifi menu, but the non-persistent randomization is missing there.

    You can find the non-persistent randomization option in the Developer menu. Most likely this option is active on your device and thus overrides all the other settings you do in Wifi menu.




Suggested Topics

  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2