Motorola Photon Q AT&T HD Voice support?



  • I have a Motorola Photon Q unlocked and running lineage. It's a 4G LTE phone and yet I'm told that it won't work after the February 22nd 3G sunset because it "doesn't support AT&T HD Voice". This is a requirement that was never mentioned to me before. Previously, all I had been told was it had to be 4G LTE.

    So, is there a way to make this phone capable of using AT&T HD Voice? Or at the very least trick it into thinking it's capable? I need this to work and I'm running out of time and options.



  • Please read the very comprehensive article about AT&T 3G shutdown + VoLTE requirement: https://www.xda-developers.com/t-mobile-att-require-volte-phone-calls-shut-down-3g/

    The most important part is that AT&T simply uses a white list of phones they have decided to support. Other phones they simply don't care about.

    Since AT&T whitelists devices for VoLTE compatibility, you won’t be able to BYOD to the carrier starting February 2022 unless the carrier changes its practices or whitelists a lot more devices. There’s no reason they can’t—VoLTE is a standard protocol, after all—but thus far they haven’t.

    Hence effectively it doesn't matter if you phone supports VoLTE and AT&T HD Voice, unless the phone is on their whitelist they will not allow you to activate the phone. For existing phones it is unclear if they will work but if you ask AT&T they will simply tell you it won't work because it is not on their list.

    So you have three choices:

    1. Believe AT&T and get a new phone
    2. Keep your phone and try it out
    3. Get this customer-unfriendly company what it deserves and switch to a provider that don't domineer over it's customers.



Suggested Topics

  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2