Hide notch on Android 11



  • I just got my Fairphone 4, and, overall the device is nice, but I can't get used to the notch.

    Since the display aspect ratio is super tall anyways and I can use a bit more bezel on the bottom as well (for a keyboard attachment that I built and used on my last phone), I figured, I'd use wm size over adb to just reduce the screen's vertical resolution and thus create bezels on top and bottom.

    But after I did that, this is what happened:

    screenshot

    Sorry for the bad picture quality.

    What happened is, it didn't remove the rounded corners and/or the notch, it just moved them farther down. So apparently, the OS doesn't seem to render the pixels behind the screen cutouts at all, and when I made the used screen area smaller, it just moved those dead zones with it. Even if I shrink the vertical resolution to 1000 pixel (which is less than half), the behaviour stays the same.

    Is there a way to disable that functionality?

    I want to end up with just a square display area.

    It would be best if I can get that only with adb/onboard stuff. If you are recommending an app for that, it should be one that doesn't have ads/microtransactions.



  • Accidentally, I had a similar problem myself recently. I believe I see USB debugging is enabled on your phone. Go into developer options and scroll 3/4 of the way down to the Drawing section. In there you have a setting called Display cutout. Change that to hide.

    Alternatively, you can root your phone and install Magisk. Inside Magisk you can install a module called None Display Cutout by MlgmXyysd. After installing, go to the same setting under developer options and select No display cutout. This module let's your phone think it doesn't even have a notch. You can play around with this but probably the first option will work best for you.




Suggested Topics

  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2