Hiding root from banking app in 2021



  • Can't use my banking app nor pass safetynet

    Completely Hid the banking app, and google store, and google services on Magisk hide. Also tried a few relevant Magisk modules:

    • Magisk Hide props config (default)
    • Systemless host (default)
    • Universal SafetyNet fix 2.1.1
    • Riru framework
    • Riru Unshare
    • Riru MomoHider

    Relevant Xposed modules:

    • RootCloak
    • SudoHide
    • XprivacyLua
    • Bancontact RootBypasser

    Also tried Island, and applying those modules above to the isolated app. No deal

    Can't disable OEM unlock, or else TWRP is blocked by some FRP

    What else can be done ?

    Samsung G935F
    Lineage OS 15.1 (Oreo 8.1)
    

    Same use to happen before, with S7's original ROM

    Important: I have other Xposed/LSPosed modules that I need:

    • ExSDCard Access Enabler (Magisk)
    • App Locale 2
    • Lucky+Patcher
    • Jasi Patcher
    • Disable-FLAG_SECURE
    • Greenify
    • Secure Settings
    • AFWall+

    And apps:

    • Titanium backup

    Second part of the question:

    How can I tell HOW the app detects root ?

    So I can possibly patch the leak... Block services... Make XprivacyLua more effective

    Maybe this second part is the most relevant here


    Third (optional) question:

    Are there any updated news regarding this cat and mouse fight ? Is someone working against this hardware verification ? Having breakthroughs ?



  • You don't need all of those modules and apps (though XprivacyLua is needed)

    I can totally understand your situation so I'll explain what i did for myself. Just follow step by step and it'll work.

    First things first, remove every magisk module (incuding systemless hosts,Unshare and Momohider - yes we dont need that) except Riru CORE framework.

    Also remove whatever xposed module you've installed except XprivacyLua (also you should be using riru lsposed, not xposed)

    Now install Riru - LSPosed, Universal safety net fix https://github.com/kdrag0n/safetynet-fix/releases/download/v1.2.0/safetynet-fix-v1.2.0.zip (not 2.1.0)

    Now follow relevant parts of https://telegra.ph/Pass-Safetynet-on-Rooted-Device-09-02-2 guide.

    DO reset data of Play services, Play store and Google Services Framework.

    Reboot and safetynet should pass.

    Feel free to comment any doubts




Suggested Topics

  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2