How to stop screen from lighting up?



  • Just received a new Motorola E6 phone. It's running Android 9.0. Any time the phone is bumped, moved, or there is any kind of vibration the screen lights up. How can I stop it from doing this?

    Internet search suggests I should find a "Sneak Peek" option under Settings - Displays, however, this phone does NOT have "Sneak Peek" or anything similar there. It also does not have an Ambient Display setting.



  • It was due to a Motorola specific feature Peek Display. Disabling that fixed the issue. Tools → Moto → Peek Display (thanks to OP for correct path - https://forums.lenovo.com/t5/Moto-G6-Moto-G6-Plus-Moto-G6/G6-wont-stop-turning-on-lighting-up/m-p/4583068 )

    On some other models disabling https://forums.lenovo.com/t5/Moto-X4/Screen-wakes-when-moved/m-p/3893085 may help.




Suggested Topics

  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2