"Unable to get VPN permissions, you may need to reboot device and try again"



  • On my Play Store-included Chinese Android phone (Xiaomi Poco X3 NFC), I recently encountered an issue where I had to re-accept permissions for all of my apps. My VPN app failed, and I began getting errors that the phone itself was preventing me from connecting to a VPN. I tried clearing the cache, the files, re-installing the app, using new VPN client and configuration files, restarting the phone, etc. None of this helped.



  • I backed up all of my data and reset the phone to factory defaults.

    Important reminder:

    Before resetting the phone, I removed my MicroSD because the dialog said that it would delete everything on the MicroSD if I did not do this.

    Sussing out the source of the problem:

    After reformatting my phone, I slowly installed each app that I thought might be the culprit. Then, I slowly did each system app update. I found there were a few apps that could cause the problem. These are the apps that I suspect have the ability to permanently block connection to VPN in order of confidence with first being most certain: Mi Credit, Screenshot (by Mi), Updater (by Mi), and Security (by Mi). There may be other system apps that create this problem.

    Update: Themes (MI) also creates this problem, consistently. The VPN connects and says that it is connected, but download rates drop to 0kbps. If I remove myself from the MI Themes privacy policy and wait a few minuets, the VPN starts working again. If I re-accept the privacy policy, the VPN stops working, again. This is reproduceable.

    Methodology:

    After reformatting, I spent a few hours connected to my VPN and browsing before installing any of these apps. After installing them one-by-one, I encountered issues. Removing updates did not undo the problem of the VPNs being blocked: I had to factory reset the phone, again. I installed these other apps, one after each reset, to test each one of them. I installed "updater" and "security" at the same time so it might be only one of these two, but I suspect that all of the system apps on the new MIUI system app update set are tainted. Finally, I reset the device, ignored all updates, turned off auto-update in three locations--Developer Options, System Apps Update settings, and System Apps Updater settings--, and began to use my phone again. Everything has been working fine for 24 hours. If it fails hereafter, I will update my answer and include it as part of the question; so, if my answer is here, the theory stands.

    How is this happening?

    If anyone knows why these apps are causing this problem or can guide me through figuring it out, please mention me in a comment. Thank you!




Suggested Topics

  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2