Skyrim Special Edition SKSE error



  • I am trying to run Skyrim Special Edition via SKSE with mods, but when I run it it gives me the error

    "You are using Skyrim version 1.5.80, which is out of date and incompatible with this version of SKSE64. Update to the latest version."

    How can I fix this?

    I've tried to run the BestofBothWorlds patcher from Nexusmods but it didn't help me. I also tried to find a patch manually but I didn't find anything. If you know where I can find a patch for the game suitable for SKSE64 please let me know.



  • Every version of Skyrim has it's own version of SKSE. You can either update your version of Skyrim - as the warning states - or download an older version of SKSE from https://skse.silverlock.org/download/archive/ , which is linked to on the team's https://skse.silverlock.org/ (which is the only legal way to get SKSE, IIRC).

    The newest version of Skyrim Special Edition version is https://en.uesp.net/wiki/Skyrim:Special_Edition_Patch . Try to update your Skyrim version using the service you're playing it on.




Suggested Topics

  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2