RMAN archive logs not deleted



  • I am working on an Oracle11gR2 database. The database is in DataGuard mode, even though the dataguard is set to DEFER.

    I want to delete all archive logs that have been backed up at least 2 times to tape.

    rman> list archivelog all backed up 2 times to device type sbt_tape;
    

    shows a list of archive logs that match the criteria

    However, when I later try to run

    rman> delete force noprompt archivelog all backed up 2 times to device type sbt_tape;
    

    no files are deleted.

    All parameters are set to default values, apart from retention policy which is set to a window of 370 days

    A look into the trace I generated, shows, among other things, this message for each of the files that were reported by the list command

    DBGMISC: Matching archived log has 0 backups
    

    which I do not know how to interpret.

    Any ideas on how to further investigate the issue would be greatly appreciated

    rman configuration is as follows

    using target database control file instead of recovery catalog
    RMAN configuration parameters for database with db_unique_name ORACLE are:
    CONFIGURE RETENTION POLICY TO RECOVERY WINDOW OF 370 DAYS;
    CONFIGURE BACKUP OPTIMIZATION OFF; # default
    CONFIGURE DEFAULT DEVICE TYPE TO DISK; # default
    CONFIGURE CONTROLFILE AUTOBACKUP OFF; # default
    CONFIGURE CONTROLFILE AUTOBACKUP FORMAT FOR DEVICE TYPE DISK TO '%F'; # default
    CONFIGURE CONTROLFILE AUTOBACKUP FORMAT FOR DEVICE TYPE SBT_TAPE TO '%F'; # default
    CONFIGURE DEVICE TYPE DISK PARALLELISM 1 BACKUP TYPE TO BACKUPSET; # default
    CONFIGURE DEVICE TYPE SBT_TAPE PARALLELISM 1 BACKUP TYPE TO BACKUPSET; # default
    CONFIGURE DATAFILE BACKUP COPIES FOR DEVICE TYPE DISK TO 1; # default
    CONFIGURE DATAFILE BACKUP COPIES FOR DEVICE TYPE SBT_TAPE TO 1; # default
    CONFIGURE ARCHIVELOG BACKUP COPIES FOR DEVICE TYPE DISK TO 1; # default
    CONFIGURE ARCHIVELOG BACKUP COPIES FOR DEVICE TYPE SBT_TAPE TO 1; # default
    CONFIGURE CHANNEL DEVICE TYPE 'SBT_TAPE' PARMS  'SBT_LIBRARY=/opt/tivoli/tsm/client/oracle/bin64/libobk.so';
    CONFIGURE MAXSETSIZE TO UNLIMITED; # default
    CONFIGURE ENCRYPTION FOR DATABASE OFF; # default
    CONFIGURE ENCRYPTION ALGORITHM 'AES128'; # default
    CONFIGURE COMPRESSION ALGORITHM 'BASIC' AS OF RELEASE 'DEFAULT' OPTIMIZE FOR LOAD TRUE ; # default
    CONFIGURE ARCHIVELOG DELETION POLICY TO NONE; # default
    CONFIGURE SNAPSHOT CONTROLFILE NAME TO '+ASMARCHIVES/oracle/snap_orcld.f';
    


  • Because you have CONFIGURE ARCHIVELOG BACKUP COPIES FOR DEVICE TYPE DISK TO 1; # default CONFIGURE ARCHIVELOG BACKUP COPIES FOR DEVICE TYPE SBT_TAPE TO 1; # default the database wants to make sure backups are made to tape and to disk. If you want it different because you only backup to tape that remove the lines about the disk backups.

    CONFIGURE CHANNEL DEVICE TYPE DISK CLEAR;
    

    you also could consider setting the ARCHIVELOG deletion policy.


Log in to reply
 


Suggested Topics

  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2