504 Gateway Time-out



  • There's a violin on the VPS, which runs once a day. In exactly 60 seconds, 504 Gateway Time-out is issued. htaccess: php_value max_execution_time 800 php_value max_input_time 800 php_value proxy_send_timeout 800 php_value proxy_read_timeout 800 php_value proxy_connect_timeout 750

    And nothing changes, even though phpini(s) and gives true meaning Where to dig?



  • You're probably getting a 504 Gateway Time-out from the Apache server, so you can try to change the Timeout, you're in the web server configuration file, most likely it's either httpd.conf or httpd-default.conf. Find these files and change this parameter:

    #
    # Timeout: The number of seconds before receives and sends time out.
    #
    Timeout 60
    

    There's one comment on your algorithm: such crypts should not be launched from the HTTP interface, but should be carried out from a command line like CRON. Making such crazy values for all the violators on the server is a way to nowhere. Imagine that you've had doing something for a very long time, and the customers have come to this address, the entire server pool can be loaded, and new clients can't just come in for your project.


Log in to reply
 


Suggested Topics

  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2