I can't put g+++ on ubuntu 12.04.5 LTS



  • There's a mistake:

    root@vm21575:~/sandbox/gitcloner# apt-get install g++
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:
    

    The following packages have unmet dependencies:
    g++ : Depends: g++-4.6 (>= 4.6.3-1~) but it is not going to be installed
    E: Unable to correct problems, you have held broken packages.

    UPD

    root@vm21575:~# apt-cache policy g++ g++-4.6
    g++:
    Installed: (none)
    Candidate: 4:4.6.3-1ubuntu5
    Version table:
    4:4.6.3-1ubuntu5 0
    500 http://archive.ubuntu.com/ubuntu/ precise/main i386 Packages
    g++-4.6:
    Installed: (none)
    Candidate: 4.6.3-1ubuntu5
    Version table:
    4.6.3-1ubuntu5 0
    500 http://archive.ubuntu.com/ubuntu/ precise/main i386 Packages
    root@vm21575:~# dpkg --get-selections | grep hold
    root@vm21575:~#

    UPD

    root@vm21575:~# aptitude -f install
    No packages will be installed, upgraded, or removed.
    0 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    Need to get 0 B of archives. After unpacking 0 B will be used.

    root@vm21575:~# aptitude install g++
    The following NEW packages will be installed:
    g++ g++-4.6{a} libc6-dev{ab} libstdc++6-4.6-dev{a}
    0 packages upgraded, 4 newly installed, 0 to remove and 0 not upgraded.
    Need to get 13.5 MB of archives. After unpacking 44.1 MB will be used.
    The following packages have unmet dependencies:
    libc6-dev : Depends: libc6 (= 2.15-0ubuntu10.15) but 2.15-0ubuntu10+openvz0 is installed.
    Depends: libc-dev-bin (= 2.15-0ubuntu10.15) but it is not going to be installed.
    Depends: linux-libc-dev but it is not going to be installed.
    The following actions will resolve these dependencies:

     Keep the following packages at their current version:
    
    1. g++ [Not Installed]
      
    2. g++-4.6 [Not Installed]
      
    3. libc6-dev [Not Installed]
      
    4. libstdc++6-4.6-dev [Not Installed]
      

    Accept this solution? [Y/n/q/?]
    No packages will be installed, upgraded, or removed.
    0 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    Need to get 0 B of archives. After unpacking 0 B will be used.

    UPD

    root@vm21575:~# apt-cache policy libc6-dev
    libc6-dev:
    Installed: (none)
    Candidate: 2.15-0ubuntu10.15
    Version table:
    2.15-0ubuntu10.15 0
    500 http://archive.ubuntu.com/ubuntu/ precise-updates/main i386 Packages
    500 http://security.ubuntu.com/ubuntu/ precise-security/main i386 Packages
    2.15-0ubuntu10+openvz0 0
    500 http://ppa.launchpad.net/izx/ovz-libc/ubuntu/ precise/main i386 Packages
    2.15-0ubuntu10 0
    500 http://archive.ubuntu.com/ubuntu/ precise/main i386 Packages

    root@vm21575:~# aptitude install g++
    The following NEW packages will be installed:
    g++ g++-4.6{a} libc6-dev{ab} libstdc++6-4.6-dev{a}
    0 packages upgraded, 4 newly installed, 0 to remove and 0 not upgraded.
    Need to get 13.5 MB of archives. After unpacking 44.1 MB will be used.
    The following packages have unmet dependencies:
    libc6-dev : Depends: libc6 (= 2.15-0ubuntu10.15) but 2.15-0ubuntu10+openvz0 is installed.
    Depends: libc-dev-bin (= 2.15-0ubuntu10.15) but it is not going to be installed.
    Depends: linux-libc-dev but it is not going to be installed.
    The following actions will resolve these dependencies:

     Keep the following packages at their current version:
    
    1. g++ [Not Installed]
      
    2. g++-4.6 [Not Installed]
      
    3. libc6-dev [Not Installed]
      
    4. libstdc++6-4.6-dev [Not Installed]
      

    Accept this solution? [Y/n/q/?] n
    The following actions will resolve these dependencies:

     Install the following packages:
    
    1. libc-dev-bin [2.15-0ubuntu10.15 (precise-security, precise-updates)]
      
    2. linux-libc-dev [3.2.0-105.146 (precise-security, precise-updates)]
      
    3. manpages [3.35-0.1ubuntu1 (precise)]
      
    4. manpages-dev [3.35-0.1ubuntu1 (precise)]
      

      Upgrade the following packages:

    5. libc-bin [2.15-0ubuntu10+openvz0 (now, precise) -> 2.15-0ubuntu10.15 (pre
      
    6. libc6 [2.15-0ubuntu10+openvz0 (now, precise) -> 2.15-0ubuntu10.15 (precis
      

    Accept this solution? [Y/n/q/?] n
    The following actions will resolve these dependencies:

     Install the following packages:
    
    1. libc-dev-bin [2.15-0ubuntu10.15 (precise-security, precise-updates)]
      
    2. linux-libc-dev [3.2.0-23.36 (precise)]
      
    3. manpages [3.35-0.1ubuntu1 (precise)]
      
    4. manpages-dev [3.35-0.1ubuntu1 (precise)]
      

      Upgrade the following packages:

    5. libc-bin [2.15-0ubuntu10+openvz0 (now, precise) -> 2.15-0ubuntu10.15 (pre
      
    6. libc6 [2.15-0ubuntu10+openvz0 (now, precise) -> 2.15-0ubuntu10.15 (precis
      

    Accept this solution? [Y/n/q/?] n
    The following actions will resolve these dependencies:

     Install the following packages:
    
    1. libc-dev-bin [2.15-0ubuntu10.15 (precise-security, precise-updates)]
      
    2. linux-libc-dev [3.2.0-105.146 (precise-security, precise-updates)]
      

      Upgrade the following packages:

    3. libc-bin [2.15-0ubuntu10+openvz0 (now, precise) -> 2.15-0ubuntu10.15 (pre
      
    4. libc6 [2.15-0ubuntu10+openvz0 (now, precise) -> 2.15-0ubuntu10.15 (precis
      

      Leave the following dependencies unresolved:

    5. libc-dev-bin recommends manpages-dev
      

    Accept this solution? [Y/n/q/?] n
    The following actions will resolve these dependencies:

     Install the following packages:
    
    1. libc-dev-bin [2.15-0ubuntu10.15 (precise-security, precise-updates)]
      
    2. linux-libc-dev [3.2.0-23.36 (precise)]
      

      Upgrade the following packages:

    3. libc-bin [2.15-0ubuntu10+openvz0 (now, precise) -> 2.15-0ubuntu10.15 (pre
      
    4. libc6 [2.15-0ubuntu10+openvz0 (now, precise) -> 2.15-0ubuntu10.15 (precis
      

      Leave the following dependencies unresolved:

    5. libc-dev-bin recommends manpages-dev
      

    Accept this solution? [Y/n/q/?] n
    The following actions will resolve these dependencies:

     Install the following packages:
    
    1. libc-dev-bin [2.15-0ubuntu10+openvz0 (precise)]
      
    2. libc6-dev [2.15-0ubuntu10+openvz0 (precise)]
      
    3. linux-libc-dev [3.2.0-105.146 (precise-security, precise-updates)]
      
    4. manpages [3.35-0.1ubuntu1 (precise)]
      
    5. manpages-dev [3.35-0.1ubuntu1 (precise)]
      



  • As it turns out, the main problem is that you've got packages from the backward repository related to openvz

    You probably have a virtual car working under control. openvzand replacing these packages with distributives can lead, for example, to incapacity (to be specified by the server administrator(s).

    programme dependant apt-get I couldn't handle that choice.

    I suggest that we use programme (although for this case) aptitudewith a much more “intellectual” dependency permit, which can draw up a few options for the required action and offer them to you.

    Example of such a proposal:

    The following actions will resolve these dependencies:
    
     Install the following packages:
    
    1. libc-dev-bin [2.15-0ubuntu10.15 (precise-security, precise-updates)]
      
    2. linux-libc-dev [3.2.0-105.146 (precise-security, precise-updates)]
      
    3. manpages [3.35-0.1ubuntu1 (precise)]
      
    4. manpages-dev [3.35-0.1ubuntu1 (precise)]
      

      Upgrade the following packages:

    5. libc-bin [2.15-0ubuntu10+openvz0 (now, precise) -> 2.15-0ubuntu10.15 (pre
      
    6. libc6 [2.15-0ubuntu10+openvz0 (now, precise) -> 2.15-0ubuntu10.15 (precis
      

    Accept this solution? [Y/n/q/?]

    It could be accepted (default action), disagreed, with n (to be computed and proposed) or to complete the work of the programme q


    In your particular case, it might be useful to accept the option in which packages are proposed from the same openvzrepository:

    The following actions will resolve these dependencies:

     Install the following packages:
    
    1. libc-dev-bin [2.15-0ubuntu10+openvz0 (precise)]
      
    2. libc6-dev [2.15-0ubuntu10+openvz0 (precise)]
      
    3. linux-libc-dev [3.2.0-105.146 (precise-security, precise-updates)]
      
    4. manpages [3.35-0.1ubuntu1 (precise)]
      
    5. manpages-dev [3.35-0.1ubuntu1 (precise)]
      




Suggested Topics

  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2