X-I Debian



  • The graphical shell, the attempt to launch the error,

    X.Org X Server 1.16.4
    Release Date: 2014-12-20
    X Protocol Version 11, Revision 0
    Build Operating System: Linux 3.16.0-4-amd64 x86_64 Debian
    Current Operating System: Linux ivan 3.16.0-4-amd64 #1 SMP Debian 3.16.7-ckt25-2 (2016-04-08) x86_64
    Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.16.0-4-amd64 root=UUID=c05e2ac2-bad3-49b8-83a2-45f0c9f0b429 ro quiet
    Build Date: 11 February 2015  12:32:02AM
    xorg-server 2:1.16.4-1 (http://www.debian.org/support) 
    Current version of pixman: 0.32.6
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
    Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    (==) Log file: "/var/log/Xorg.0.log", Time: Sun May 29 19:23:28 2016
    (==) Using config file: "/etc/X11/xorg.conf"
    (==) Using system config directory "/usr/share/X11/xorg.conf.d"
    (EE) 
    Fatal server error:
    (EE) no screens found(EE) 
    (EE) 
    Please consult the The X.Org Foundation support 
         at http://wiki.x.org
     for help. 
    (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
    (EE) 
    (EE) Server terminated with error (1). Closing log file.
    xinit: giving up
    xinit: unable to connect to X server: Connection refused
    xinit: server error
    

    Xorg.0.log:

    [    49.070] 
    X.Org X Server 1.16.4
    Release Date: 2014-12-20
    [    49.070] X Protocol Version 11, Revision 0
    [    49.071] Build Operating System: Linux 3.16.0-4-amd64 x86_64 Debian
    [    49.071] Current Operating System: Linux ivan 3.16.0-4-amd64 #1 SMP Debian 3.16.7-ckt25-2 (2016-04-08) x86_64
    [    49.071] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.16.0-4-amd64 root=UUID=c05e2ac2-bad3-49b8-83a2-45f0c9f0b429 ro quiet
    [    49.071] Build Date: 11 February 2015  12:32:02AM
    [    49.072] xorg-server 2:1.16.4-1 (http://www.debian.org/support) 
    [    49.072] Current version of pixman: 0.32.6
    [    49.072]    Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
    [    49.073] Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    [    49.074] (==) Log file: "/var/log/Xorg.0.log", Time: Sun May 29 22:39:53 2016
    [    49.075] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
    [    49.075] (==) No Layout section.  Using the first Screen section.
    [    49.075] (==) No screen section available. Using defaults.
    [    49.075] (**) |-->Screen "Default Screen Section" (0)
    [    49.075] (**) |   |-->Monitor "<default monitor>"
    [    49.075] (==) No monitor specified for screen "Default Screen Section".
        Using a default monitor configuration.
    [    49.075] (==) Automatically adding devices
    [    49.075] (==) Automatically enabling devices
    [    49.075] (==) Automatically adding GPU devices
    [    49.075] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
    [    49.075]    Entry deleted from font path.
    [    49.075] (==) FontPath set to:
        /usr/share/fonts/X11/misc,
        /usr/share/fonts/X11/100dpi/:unscaled,
        /usr/share/fonts/X11/75dpi/:unscaled,
        /usr/share/fonts/X11/Type1,
        /usr/share/fonts/X11/100dpi,
        /usr/share/fonts/X11/75dpi,
        built-ins
    [    49.075] (==) ModulePath set to "/usr/lib/xorg/modules"
    [    49.075] (II) The server relies on udev to provide the list of input devices.
        If no devices become available, reconfigure udev or disable AutoAddDevices.
    [    49.075] (II) Loader magic: 0x7fe2003f8d80
    [    49.075] (II) Module ABI versions:
    [    49.075]    X.Org ANSI C Emulation: 0.4
    [    49.075]    X.Org Video Driver: 18.0
    [    49.075]    X.Org XInput driver : 21.0
    [    49.075]    X.Org Server Extension : 8.0
    [    49.075] (II) xfree86: Adding drm device (/dev/dri/card0)
    [    49.077] (--) PCI:*(0:1:0:0) 10de:06e9:103c:1505 rev 161, Mem @ 0xd2000000/16777216, 0xc0000000/268435456, 0xd0000000/33554432, I/O @ 0x00005000/128
    [    49.077] (II) LoadModule: "glx"
    [    49.078] (II) Loading /usr/lib/xorg/modules/linux/libglx.so
    [    49.078] (EE) Failed to load /usr/lib/xorg/modules/linux/libglx.so: /usr/lib/xorg/modules/linux/libglx.so: cannot open shared object file: No such file or directory
    [    49.078] (II) UnloadModule: "glx"
    [    49.078] (II) Unloading glx
    [    49.078] (EE) Failed to load module "glx" (loader failed, 7)
    [    49.078] (==) Matched nouveau as autoconfigured driver 0
    [    49.078] (==) Matched nv as autoconfigured driver 1
    [    49.078] (==) Matched nouveau as autoconfigured driver 2
    [    49.078] (==) Matched nv as autoconfigured driver 3
    [    49.078] (==) Matched modesetting as autoconfigured driver 4
    [    49.078] (==) Matched fbdev as autoconfigured driver 5
    [    49.078] (==) Matched vesa as autoconfigured driver 6
    [    49.078] (==) Assigned the driver to the xf86ConfigLayout
    [    49.078] (II) LoadModule: "nouveau"
    [    49.078] (II) Loading /usr/lib/xorg/modules/drivers/nouveau_drv.so
    [    49.078] (II) Module nouveau: vendor="X.Org Foundation"
    [    49.078]    compiled for 1.16.0, module version = 1.0.11
    [    49.078]    Module class: X.Org Video Driver
    [    49.078]    ABI class: X.Org Video Driver, version 18.0
    [    49.078] (II) LoadModule: "nv"
    [    49.079] (WW) Warning, couldn't open module nv
    [    49.079] (II) UnloadModule: "nv"
    [    49.079] (II) Unloading nv
    [    49.079] (EE) Failed to load module "nv" (module does not exist, 0)
    [    49.079] (II) LoadModule: "modesetting"
    [    49.079] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
    [    49.079] (II) Module modesetting: vendor="X.Org Foundation"
    [    49.079]    compiled for 1.16.4, module version = 0.9.0
    [    49.079]    Module class: X.Org Video Driver
    [    49.079]    ABI class: X.Org Video Driver, version 18.0
    [    49.079] (II) LoadModule: "fbdev"
    [    49.080] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
    [    49.080] (II) Module fbdev: vendor="X.Org Foundation"
    [    49.080]    compiled for 1.15.99.904, module version = 0.4.4
    [    49.080]    Module class: X.Org Video Driver
    [    49.080]    ABI class: X.Org Video Driver, version 18.0
    [    49.080] (II) LoadModule: "vesa"
    [    49.080] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
    [    49.080] (II) Module vesa: vendor="X.Org Foundation"
    [    49.080]    compiled for 1.15.99.904, module version = 2.3.3
    [    49.080]    Module class: X.Org Video Driver
    [    49.080]    ABI class: X.Org Video Driver, version 18.0
    [    49.080] (II) NOUVEAU driver Date:   Thu Aug 28 03:57:48 2014 +0200
    [    49.080] (II) NOUVEAU driver for NVIDIA chipset families :
    [    49.080]    RIVA TNT        (NV04)
    [    49.080]    RIVA TNT2       (NV05)
    [    49.080]    GeForce 256     (NV10)
    [    49.080]    GeForce 2       (NV11, NV15)
    [    49.080]    GeForce 4MX     (NV17, NV18)
    [    49.080]    GeForce 3       (NV20)
    [    49.080]    GeForce 4Ti     (NV25, NV28)
    [    49.080]    GeForce FX      (NV3x)
    [    49.080]    GeForce 6       (NV4x)
    [    49.081]    GeForce 7       (G7x)
    [    49.081]    GeForce 8       (G8x)
    [    49.081]    GeForce GTX 200 (NVA0)
    [    49.081]    GeForce GTX 400 (NVC0)
    [    49.081] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
    [    49.081] (II) FBDEV: driver for framebuffer: fbdev
    [    49.081] (II) VESA: driver for VESA chipsets: vesa
    [    49.081] (++) using VT number 1
    

    [ 49.081] (--) controlling tty is VT number 1, auto-enabling KeepTty
    [ 49.082] (EE) [drm] KMS not enabled
    [ 49.082] (EE) [drm] KMS not enabled
    [ 49.082] (EE) [drm] KMS not enabled
    [ 49.083] (EE) [drm] KMS not enabled
    [ 49.083] (EE) [drm] KMS not enabled
    [ 49.083] (WW) Falling back to old probe method for modesetting
    [ 49.083] (II) Loading sub module "fbdevhw"
    [ 49.083] (II) LoadModule: "fbdevhw"
    [ 49.083] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
    [ 49.083] (II) Module fbdevhw: vendor="X.Org Foundation"
    [ 49.083] compiled for 1.16.4, module version = 0.0.2
    [ 49.083] ABI class: X.Org Video Driver, version 18.0
    [ 49.083] (EE) open /dev/fb0: No such file or directory
    [ 49.083] (WW) Falling back to old probe method for fbdev
    [ 49.083] (II) Loading sub module "fbdevhw"
    [ 49.083] (II) LoadModule: "fbdevhw"
    [ 49.083] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
    [ 49.083] (II) Module fbdevhw: vendor="X.Org Foundation"
    [ 49.083] compiled for 1.16.4, module version = 0.0.2
    [ 49.083] ABI class: X.Org Video Driver, version 18.0
    [ 49.083] (EE) open /dev/fb0: No such file or directory
    [ 49.083] vesa: Ignoring device with a bound kernel driver
    [ 49.083] (WW) Falling back to old probe method for vesa
    [ 49.083] (EE) Screen 0 deleted because of no matching config section.
    [ 49.083] (II) UnloadModule: "modesetting"
    [ 49.083] (EE) Screen 0 deleted because of no matching config section.
    [ 49.083] (II) UnloadModule: "fbdev"
    [ 49.083] (II) UnloadSubModule: "fbdevhw"
    [ 49.083] (EE) Screen 0 deleted because of no matching config section.
    [ 49.083] (II) UnloadModule: "vesa"
    [ 49.083] (EE) Device(s) detected, but none match those in the config file.
    [ 49.083] (EE)
    Fatal server error:
    [ 49.083] (EE) no screens found(EE)
    [ 49.084] (EE)
    Please consult the The X.Org Foundation support
    at http://wiki.x.org
    for help.
    [ 49.084] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
    [ 49.084] (EE)
    [ 49.085] (EE) Server terminated with error (1). Closing log file.

    I tried to stop Nvidia-kernel, drop config, not helping.

    UPD: I've got a new log, now the mistakes are different.



  • [49.078] (EE) Failed to load /usr/lib/xorg/modules/linux/libglx.so: /usr/lib/xorg/modules/linux/libglx.so: cannot open shared object file: No such file or directory
    

    That says something. Check the bag. libglx (I don't know the full name (from debiana to arth (manjaro) and there was no problem), search through. apt-cache search)




Suggested Topics

  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2