How do you stop the cable approaching the ObjectManager?



  • The API Indictment cards are telling how to disconnect this behavior for Clusterer and for individual clusters, but ObjectManager There's nothing to say separately. Trying to use it. manager.clusters.options.set - but it doesn't work, or I don't write the name of the parameter right.

    Trying to do this:

            var map = new ymaps.Map("map", {
                center: [64.56572586, 102.06531243],
                zoom: 3,
                controls: [],
            })
    
        var manager = new ymaps.ObjectManager({
            clusterize: true,
        })
        manager.clusters.options.set('disableClickZoom', true)
        manager.clusters.options.set('clusterDisableClickZoom', true)
        map.geoObjects.add(manager);
    
        manager.add([1,2].map(function (index) {
          return { 
            id: index,
            type: 'Feature',
            geometry: {
               type: 'Point',
               coordinates: [64.56572586, 102.06531243],
            }
          }
        }))
    

    Similar code using Clusterer and GeoObject It works, but I'd like to use it. ObjectManager



  • From the Documents Department:

    The cluster ops are sent with a prefixed cluster. List of options in ClusterPlacemark class description;

    I mean, it'll be like this:

    objectManager = new ymaps.ObjectManager({
        clusterize: true,
        clusterDisableClickZoom: true
    });
    

    The default function of click processing is, however, starting to work. I don't know how to turn it off.


Log in to reply
 


Suggested Topics

  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2