error: illegal character in xamarin app



  • In an attempt to compute an annex to Debug mode, it makes such a mistake.

    C:\Program Files (x86)\Java\jdk1.7.0_71\\bin\javac.exe -J-Dfile.encoding=UTF8 -d obj\Debug\android\bin\classes -classpath "C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\MonoAndroid\v6.0\mono.android.jar;C:\Users\nemes\AppData\Local\Xamarin\Android.Support.v4\23.0.1.3\embedded\classes.jar;C:\Users\nemes\AppData\Local\Xamarin\Android.Support.v4\23.0.1.3\embedded\libs\internal_impl-23.0.1.jar;C:\Users\nemes\AppData\Local\Xamarin\Android.Support.v7.AppCompat\23.0.1.3\embedded\classes.jar;C:\Users\nemes\AppData\Local\Xamarin\Android.Support.v7.MediaRouter\23.0.1.3\embedded\classes.jar;C:\Users\nemes\AppData\Local\Xamarin\Android.Support.v7.MediaRouter\23.0.1.3\embedded\libs\internal_impl-23.0.1.jar;C:\Users\nemes\AppData\Local\Xamarin\Android.Support.v7.RecyclerView\23.0.1.3\embedded\classes.jar;C:\Users\nemes\AppData\Local\Xamarin\GooglePlayServices.Base\8.1.0\embedded\classes.jar;C:\Users\nemes\AppData\Local\Xamarin\GooglePlayServices.Basement\8.1.0\embedded\classes.jar;C:\Users\nemes\AppData\Local\Xamarin\GooglePlayServices.Maps\8.1.0\embedded\classes.jar" -bootclasspath C:\Users\nemes\AppData\Local\Android\android-sdk\platforms\android-23\android.jar -encoding UTF-8 "@C:\Users\nemes\AppData\Local\Temp\tmp4C9E.tmp" 
    
    obj\Debug\android\src\com\companyname\murakami_kiev\R.java:1: error: illegal character: \0
    

    I've been reading the CO, that the problem with the file coding, but I understand R.java is automatically generated.
    How can you fix that?

    It's okay to start the Release mode and the application starts on the phone.



  • I figured it out.

    Just drank R.java's file and scooped it again.




Suggested Topics

  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2