Permission of dependency



  • I'm trying to get a test run with a text interface. As a library http://hackage.haskell.org/package/vty

    Code:

     import Graphics.Vty.Widgets.All
     import qualified Data.Text as T
    

    main :: IO ()
    main = do
    e <- editWidget
    ui <- centered e

    fg <- newFocusGroup
    addToFocusGroup fg e

    c <- newCollection
    addToCollection c ui fg

    e onActivate \this ->
    getEditText this >>= (error. ("You entered: " ++))

    runUi c defaultContext

    After launch stack build Receiving the following communication:

     $ stack build
    While constructing the BuildPlan the following exceptions were encountered:

    -- Failure when adding dependencies:
    vty-ui: needed (-any), couldn't resolve its dependencies
    needed for package: LearnHaskell-0.1.0.0

    -- Failure when adding dependencies:
    QuickCheck: needed (>=2.4 && <2.8), 2.8.1 found (latest version available)
    needed for package: vty-ui-1.9

    If I understand it correctly, there's a QuickCheck module for the vty-ui-1.9 package, but at this point, module 2.8.1

     QuickCheck: needed (>=2.4 && <2.8), 2.8.1 found (latest version   available)
    needed for package: vty-ui-1.9

    How can this conflict be resolved?



  • How can this conflict be resolved?

    Maybe help. https://stackoverflow.com/a/5140957/4827341 :

    cabal install QuickCheck-2.8
    

Log in to reply
 


Suggested Topics

  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2