How to do version compatibility testing



  • I have an App ver - 3.8 and minimum supported version is 4.0. If the App is older than 4.0, an update available is shown to the User within the App. Is there a way to simulate or test this scenario



  • To test any thing is to simulate the conditions necessary to for the thing to happen and see if the thing happens.

    To paraphrase what Dan Wilson said. If you want to see if v3.8 of an app prompts for an update, load v3.8 and see if it prompts for an update.

    When you're working with multiple versions it helps to have a standard procedure for setting up the testing environment with with any supported version of your software.




Suggested Topics

  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2