Disable Uplay overlay on Steam



  • I am trying to play Assassin's creed Odyssey on Ubuntu 18 with Proton 5.13-4 on Steam. The game is running but a balloon asking to shift+f2 to open Uplay is constantly on the top right corner of the screen. If I click do shift+f2, Uplay overlay opens up, but I am unable to close it. The game becomes stuck at that point and just crashes.

    Can I disable this Uplay nonsense in steam? I tried out adding -uplay_steam_mode as a launch option as suggested by one of the Ubisoft Fourm (which I can't find anymore) but that did not work. Any suggestions?



  • had the same problem and found a workaround: just start the game and press shift+F2, then disable all notification types, crash the game and restart... should be fine now 🙂




Suggested Topics

  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2