In Empire: Total War, when a building can fit 1000+ soldiers, why can only one 120-soldier unit enter?



  • In Empire: Total War, sometimes garrisonable buildings can supposedly fit thousands of soldiers inside - you can see this by hovering your mouse over them and looking at their information - but you can usually only tell one unit to actually enter the building. Other units might initially march to the building, but once the first unit's inside, other units will just stop right outside the door.

    There are also cases when this is not so. I remember, on at least one or two occasions, moving two separate units into the same building at the same time.

    Why is it then that, much of the time, only one unit will enter a building, regardless of how many men can supposedly fit into it? Is there some sort of special way you have to click on the thing to get subsequent units to go in or something? Is this just an outright bug? Thanks.



  • Some buildings will allow multiple units inside, others will not - even though in both cases the maximum capacity greatly exceeded the number of men in both units. It also takes an extremely long amount of time for those men to enter or leave the garrison, and I've had units stop halfway (despite easily having enough room) and half the men are standing outside getting slaughtered. Chalk it up to the usual bugginess of Total War games I suppose. Occasionally you'll be presented with an 'X' when trying to garrison a second unit, other times the unit just won't go inside.

    Personally, I would advise against using buildings as garrisons anyway - besides the bugs, it greatly reduces the unit's firepower (fewer soldiers firing), makes them almost completely immobile for a huge stretch of time, and makes them susceptible to artillery. Plus if they rout during melee, they will get slaughtered as they try to run past the enemy unit entering the building.

    I found a few links discussing the issue on various forums:

    http://shoguntotalwar.yuku.com/topic/46060/Multiple-Units-in-Buildings-BUG#.U4amMfkwB7k

    http://etw.heavengames.com/cgi-bin/forums/display.cgi?action=ct&f=10,8430,100,all


Log in to reply
 


Suggested Topics

  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2