Setting up a dedicated server on my PC



  • I'm trying to set up a dedicated server of CS: GO on my machine because they've gone and taken away the listen server capabilities it seems. The fools! Alls I want to do is practice some stuff, nades and what not.

    Anyway, I have the following command:

    srcds -game csgo -ip x.x.x.x -port 27015 -console -usercon +game_type 0 +game_mode 1 +mapgroup mg_allclassic +map de_inferno

    I've done done any changes to the server, just a fresh install from SteamCMD and into that command.

    I get:

    CreateBoundSocket: ::bind returned error [no name available](10049)
    Could not establish connection to Steam server.
    

    Extra info:

    I'm running Windows 7 64bit, have added the server to the firewall rules and also forwarded port 29015 on my router to this machine. It's been a while since I've done this so perhaps I've done it wrong:

    Protocol    Port Range    Translate To    Trigger Protocol     Trigger Port
    Any         27105         27015           -                    -
    

    Odly my machine didn't appear on the list of devices so I just entered the IP address. I have a BT home hub (not 100% which version. A black curvy one).

    edit: spotted a slight mistake where I had the port as 29015, port rage as the same and translate to as 27015. Corrected this and it's no different.

    Update

    I tried +port and +ip instead and got different error output:

    NET_GetBindAddresses found 192.168.12.201: 'Killer e2200 PCI-E Gigabit Ethernet Controller (NDIS 6.20)'
    WARNING: NET_OpenSocket: bind: WSAEADDRNOTAVAIL
    Trying to open socket on 192.158.1.201
    (Repeat a few time)
    Socket bind failed (WSAEADDRNOTAVAIL)
    Network: IP x.x.x.x mode MP, dedicated No, ports 27015 sv / 27005 CL
    

    LAN issue

    I thought I'd at least try and getting it locally before I expose it to the public. It appears in my LAN tab and I can attempt to connect, but instead I get this in the client console:

    Server requires lobby reservation but is unreserved.

    Please note this is an utterly fresh install and I have done nothing but try and fire it up. No config files or whatever.

    Ports

    I'm not sure my router is doing its job here as http://www.canyouseeme.org/ reports a failure.



  • Try adding the following to your server config:

    sv_allow_lobby_connect_only 0
    sv_dc_friends_reqd 0
    



Suggested Topics

  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2