Has anyone been able to run Assassin's Creed 1 on Windows 7?



  • Please note that I'm talking about Assassin's Creed 1 and not 2. I know that 2 supports Windows 7. It's part 1 that I'm concerned about.

    I had installed that game sometime a while back but had been unable to run it on Windows 7. On running it, I get a black screen. I don't know whether thats a specific problem or everyone is having it.

    So, is there anyone who has been able to run it successfully on Windows 7 with an on-board graphics card? And if yes, what steps specifically did you follow?

    Edit: I tried the test at http://www.systemrequirementslab.com and it passed everything except the graphics card name test - shows up as unrecognized. However, every component of the graphics card passed the test.

    2nd Edit: You can also try out Swiftshader and 3d Analyze in case you are trying to install. If it works out, please let me know the settings.



  • I have Windows 7 and am playing Assassin's Creed 1 right now with no problems whatsoever. I don't have a very powerful machine, with a 2.9 GHz Core 2 Duo Processor with 1 GB RAM and an onboard graphics card Intel G41 Express Chipset, so it does run, although only on the lower end of graphics and detail settings, but well and fast. The problem with you is most likely in the copy of the game you have, perhaps with some missing files. If not that, then it's surely a problem with the graphics card. Not that it's not fast enough, but because it's not compatible with the processor you have.



Suggested Topics

  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2