Can I get Dishonored to stop asking for admin access whenever I run it?



  • Every time I run Dishonored under Steam I get a pop up asking me for my Administrator password (I run as a normal user account, I imagine a UAC prompt would come up if I was running as Admin). I think this is due to the Steam first-time setup being run every time.

    Is there any way to correct this issue?



  • You will need administrator rights to apply this fix

    According to a Steam forums post:

    You should launch regedit (runnable via Win + R) and navigate to HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Valve\Steam\Apps\205100, right mouseclick on the right pane and click "new DWORD" (32-bit), name it "PhysXRedist" and give it a value of 1.

    Restart the game and it shouldn't bug you anymore.


    If you don't feel comfortable going into the registry yourself, run one of these commands instead depending on your version of Windows:

    32-bit Windows:

    reg add HKLM\SOFTWARE\Valve\Steam\Apps\205100 /v PhysXRedist /t REG_DWORD /d 1 /f
    

    64-bit Windows:

    reg add HKLM\SOFTWARE\Wow6432Node\Valve\Steam\Apps\205100 /v PhysXRedist /t REG_DWORD /d 1 /f
    



Suggested Topics

  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2