How can I turn off fast running on the Smart Moving mod?



  • We have smart moving installed on my server. It has a feature that if you press 'O' or 'I' you move speed can be increased by a percentage. I've tested this and I've moved across the map at 3000%+ the normal speed of moving. Because we feel this is a way to cheat, I've decided that I want to turn this off on our server.

    I've looked all over the smart moving config file for my server. I see two sections:

    • Standard Sprinting (Vanilla Minecraft's implementation)
    • Generic Sprinting (Smart Moving's implementation)

    Here is content for those sections:

    # =====================================================================
    # Standard sprinting
    # ------------------
    # Below you find the options for standard vanilla Minecraft sprinting
    # (sometimes referred as "running" here)
    # =====================================================================
    
    # To switch on/off standard sprinting
    move.run:true
    
    # Standard sprinting factor (>= 1.1)
    move.run.factor:1.3
    
    # To switch on/off standard sprinting exhaustion
    move.run.exhaustion:false;h:true
    
    
    # Maximum exhaustion to start a standard sprint (>= 0)
    move.exhaustion.run.start:75
    
    # Maximum exhaustion to continue a standard sprint (>= "move.exhaustion.run.start")
    move.exhaustion.run.stop:100
    
    # Exhaustion gain factor while standard sprinting (>= 0)
    move.exhaustion.run.gain.factor:1.5
    
    
    
    
    # =====================================================================
    # Generic sprinting
    # -----------------
    # Below you find the options for Smart Moving's generic sprinting
    # available for many different smart movings plus standard walking
    # =====================================================================
    
    # To switch on/off generic sprinting
    move.sprint:false
    
    # Generic sprinting factor (>= 1.1 AND >= 'move.run.factor' + 0.1 if relevant)
    move.sprint.factor:1.5
    
    # To switch on/off sprinting exhaustion
    #! Interpreted value "true" is ignored because the default value of property "move.sprint" is "false" !#
    move.sprint.exhaustion:true;e:false
    

    As you can see, I've turned SM's sprinting off but it doesn't seem to prevent the ability to increase your speed. Do you know what setting I should be changing?



  • To turn off the speed keys set move.speed.user to false in your configuration:

    move.speed.user:false
    


Suggested Topics

  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2