Uru Graphics issues with Windows 7 - Strange brightness mostly on plants



  • The other day I decided I want to play Uru again, as I had just upgraded my sound system (to 7.1 surround) and had yet to play it on my new computer. My computer is a Windows 7 64 bit HP Pavilion g6 laptop with 4gb RAM, 2.1ghz duel core with a Radeon HD 6470m - More than enough to play Uru with. I started the game and made my character, all was well. However when I hit "Play" and the intro vid started I got this:

    Uru Intro Vid issues

    I said to myself "what the heck" and moved on, a bit annoyed that I didn’t get to see the vid, but I had seen it before so I could live with it. However I found that the issue persists in the game, creating strange artefacts (hope that’s the correct use of the term) with the plant life, and other issues, namely with the ground. The common thing out of all this I can see is the colour. It all seems to a bright white / light blue colour to it in most cases.

    I looked around on the internet, but could finding nothing to help me, mainly things about running Uru on Windows 7.

    Does anyone know anything I could do to fix this? The game ran fine on my old XP computer, but sadly that computer's graphics were rubbish, and the whole computers a bit old. I really want to replay this great game - Any help would be gladly welcomed and appreciated - Thanks

    (These are the settings I'm running Uru on)

    Uru Settings

    Uru 1

    Uru 2



  • Try running it in XP Compatibility Mode. The game was made about 9 years ago, with a custom engine, way before Windows Vista or 7 were shipped (or even working), and as such may not be completely compatible with the new features of those operating systems.



Suggested Topics

  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2