J Meter Web Driver Sampler does not navigate to the url Specified



  • Can someone please help me on the problem below: I have added a ThreadGroup and Firefox driver config and Web Driver Sampler. I have just written the below code in Web Driver Sampler:

    WDS.sampleResult.sampleStart()
    WDS.browser.get('http://google.com')
    WDS.sampleResult.sampleEnd()
    

    When I save this and run, the Firefox browser is getting launched, but it is not navigating to 'http://google.com'.

    Can anyone please let me know why this is happening. I have tried this in 2 versions of Firefox, with the same result.



  • You should use the latest version of JMeter, Firefox and Webdriver plugin.

    • WebDriver Sampler plugin 1.3.0 supports Firefox 39
    • WebDriver Sampler plugin 1.2.1 supports Firefox 33
    • WebDriver Sampler plugin 1.2.0 supports Firefox 26

    Once everything is downloaded and configured you will need to delete these files (if not already deleted) from you JMeter lib directory:-

    - httpclient-4.2.6.jar

    - httpcore-4.2.5.jar

    - httpmime-4.2.6.jar

    Because you will see that every jar file which is mentioned above will be having two versions like httpmime-4.2.6.jar and httpmime-4.5.jar and you need the latest one only, so while your JMeter is closed, delete these old version of files. After that run your script, it should execute correctly.

    For more details refer to the link The WebDriver Sampler: Your Top 10 Questions Answered


Log in to reply
 

Suggested Topics

  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2
  • 2